Fellow Rider Needs Help Diagnosing Yamaha R6 Electrical Issue

Help this guy out folks. I’m not an expert but I know there are people on here who are.
I saw your page on facebook and have been looking around for help, I’d really appreciate it. I own a 1999 R6 that I am having problems with, and would appreciate the help. To start off, I am having major problems with the bike to ignite, It just keeps getting worse, it idles but it takes many tries before it actually starts, recently, I tried somany times it killed my battery cause it wouldnt start.. If i dont ride for a week or longer my battery dies. Recently I borrowed a battery from a buddy of mine with a bike, and my bike started up fine with his battery.
Second when the bike is on, my headlights are dim, once I accelerate they brighten up alot more.. what Im more worried about though its the whole starting problem.. Its a big problem to me.. What do you think this problem is? I have been trying to do some research and it seems to be pointing towards a stator or voltage regulator problem.. I WOULD GREATLY APPRECIATE THE HELP!!!
I recommended this but I know I don’t know enough:

First off you need to know I’m not a Yamaha mechanic. All the knowledge I have comes from working on my 2006 R6 and I never experienced trouble such as yours.

From what your telling me it sounds like you have a bad battery. A new battery with a Battery Tender 021-0123 Battery Tender Junior 12V Battery Charger sounds like it should cure those problems. But I don’t know for sure.

If the battery is good then I can’t imagine another problem other than the stator, which is essentially an alternator.

What do you fellow riders think?

Comments Closed

Previous post:

Next post: